Subject: [lvs-users] what happens if real servers in lvs/nat as a client to access Internet?

From: "XUFENG" <[email-masked]>
Date: Thu, 5 Mar 2009 11:35:30 +0800

Hi all,
We want to set up the following:

Internet server: 111.111.111.111 sshd port:22
LoadBalancer VIP 122.122.122.122:80 (eth0)
LoadBalancer DIP 10.0.0.9 (eth1)
Real server1:10.0.0.10(eth1) httpd port:80
On LoadBalancer we have iptables with no rules at all.(Default ACCEPT).
On Real server1 we set the default gateway as 10.0.0.9, also we have
iptables with no rules at all.(Default ACCEPT).

I know it works well if clients from outside world access services provided
on VIP:80.
But what happens on loadbalancer (which has no iptables NAT rules in itself)
if real servers(10.0.0.10) in lvs/nat as a client to access
Internet(111.111.111.111:22)?
How are the packets changed or handled on loadbalancer when it receives
requests from 10.0.0.10 with a dst address 111.111.111.111 dst port 22 and
receives responses from 111.111.111.111?
Thanks in advance.

Yours,
XUFENG
>From China.

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Joseph Mack NA3T <[email-masked]>
Date: Thu, 5 Mar 2009 04:29:52 -0800 (PST)

On Thu, 5 Mar 2009, XUFENG wrote:

there's some info on F5 SNAT in the HOWTO

> Internet(111.111.111.111:22)?

look in the HOWTO for clients on realservers

Joe
-- 
Joseph Mack NA3T EME(B,D), FM05lw North Carolina
jmack (at) wm7d (dot) net - azimuthal equidistant map
generator at http://www.wm7d.net/azproj.shtml
Homepage http://www.austintek.com/ It's GNU/Linux!