Subject: [lvs-users] difference between F5 NAT solution and LVS/NAT mode

From: "XUFENG" <[email-masked]>
Date: Thu, 5 Mar 2009 11:34:35 +0800

Hi all,

I have been using LVS with Direct Routing(DR) for years in my production.
Now I am turning to lvs/nat for some research and find that the thought
behind lvs/nat is quite simple and easy to understand.
I am not familiar with F5 loadbalancing products and only have a basic
understanding that they (F5) are basically NAT devices (when we use them in
layer 4 loadbalancing solutions).

Can someone give me a clear and simple picture of the difference between F5
NAT solution and LVS/NAT mode?

Any links to the documentation of F5 solutions will be welcomed.

Thank you in advance.

Yours,
XUFENG
>From China.

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Malcolm Turnbull <[email-masked]>
Date: Thu, 5 Mar 2009 10:02:26 +0000

XUFENG,

>From my limited knowledge:
LVS NAT mode and F5 NAT mode are identical (F5 probably has more
helper modules though for complex protocols).
>From a layer 4 perspective they are very similar in performance and features.

However a lot of F5 setups use layer 7 proxy features either full
non-transparent proxy mode or transparent proxy & NAT combined.
This is very flexible for people with legacy applications / infrastructure.

2009/3/5 XUFENG <[email-masked]>

--
Regards,

Malcolm Turnbull.

Loadbalancer.org Ltd.
Phone: +44 (0)870 443 8779
http://www.loadbalancer.org/