Subject: [lvs-users] LVS Connection Hash Table Size

From: "XUFENG" <[email-masked]>
Date: Fri, 6 Mar 2009 10:35:42 +0800

Hi
It says that 'Using a big IPVS connection hash table will greatly reduce
conflicts when there are hundreds of thousands of connections in the hash
table. ' on http://kb.linuxvirtualserver.org/wiki/Performance_and_Tuning and
it points out that 'We can configure the size of IPVS connection hash table
before compiling the Linux kernel.'

Is there another way to tune this parameter (IPVS connection table size)
besides recompiling the Linux kernel?

Yours,
XUFENG
>From China.

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Graeme Fowler <[email-masked]>
Date: Fri, 06 Mar 2009 09:54:45 +0000

> besides recompiling the Linux kernel?

Unfortunately not, no. There was a thread either here or on lvs-devel a
few weeks ago about this very factoid.

Of course, if you have everything modular then all you need is the
recompiled module (rather than the whole kernel) but that's an exercise
for the reader :)

Graeme

---

From: Joseph Mack NA3T <[email-masked]>
Date: Fri, 6 Mar 2009 04:29:52 -0800 (PST)

>> besides recompiling the Linux kernel?

read the HOWTO on changing the table size

Joe

-- 
Joseph Mack NA3T EME(B,D), FM05lw North Carolina
jmack (at) wm7d (dot) net - azimuthal equidistant map
generator at http://www.wm7d.net/azproj.shtml
Homepage http://www.austintek.com/ It's GNU/Linux!

---

From: "Gary W. Smith" <[email-masked]>
Date: Mon, 9 Mar 2009 17:21:07 -0700

Joe, 
 
I wanted to chime in on this and ask another question.  I've read the article in the how to some time ago and my basic understanding is that if we leave the bucket at the default there is no real fear of loosing any connections as long as we have enough ram (as each of the buckets can have any number of connections).
 
So is the assumption that large amounts of memory (2gb+) should be able to handle pretty much an unlimited number of connections?

________________________________

From: [email-masked] on behalf of Joseph Mack NA3T
Sent: Fri 3/6/2009 4:29 AM
To: LinuxVirtualServer.org users mailing list.
Subject: Re: [lvs-users] LVS Connection Hash Table Size

Joe

---

From: Joseph Mack NA3T <[email-masked]>
Date: Mon, 9 Mar 2009 18:48:35 -0700 (PDT)

On Mon, 9 Mar 2009, Gary W. Smith wrote:

> Joe,
>
> I wanted to chime in on this and ask another question. 
> I've read the article in the how to some time ago and my 
> basic understanding is that if we leave the bucket at the 
> default there is no real fear of loosing any connections 
> as long as we have enough ram (as each of the buckets can 
> have any number of connections).

yes

> So is the assumption that large amounts of memory (2gb+) 
> should be able to handle pretty much an unlimited number 
> of connections?

a connection uses about 112 bytes (forget exactly what). 
Ignoring memory taken by the kernel, apps etc, you can have 
2G/112 simultaneous connections.

Changing the number of buckets doesn't change the number of 
connnections that can be stored, only the number of buckets 
in which they're stored.

Joe

---

From: "Gary W. Smith" <[email-masked]>
Date: Mon, 9 Mar 2009 20:53:20 -0700

> connnections that can be stored, only the number of buckets

So I'm looking at about 15M connections.  I can live with that.  

Thanks, 

Gary