Subject: [lvs-users] cannot connect to real server

From: Nelson Serafica <[email-masked]>
Date: Thu, 19 Mar 2009 15:49:10 +0800

I already setup my rules in ipvsadm. However, its not connecting to the real server. Here is the procedure in my VIP

(not real ip address)

ipvsadm -A -t 202.81.26.31:80 -s wlc
ipvsadm -a -t 202.81.26.31:80 -r 202.81.26.40:80 -i -w 1
ipvsadm -a -t 202.81.26.31:80 -r 202.81.26.35:80 -i -w 2

I also enable tcp forwarding "echo 1 > /proc/sys/net/ipv4/ip_forward" just to be sure it can forward packets.

I'm also sure I can telnet to port 80 both on 202.81.26.40 and 202.81.26.35 but still I can't telnet using 202.81.26.31

Is there a problem in my sample configuration? Do I need to configure something on the real server.

I tried to disable selinux and iptables and do again a telnet but it is still unaccessible to 202.81.26.31.

Here is the result of ipvsadm -L

[root@LVS ~]# ipvsadm -L
IP Virtual Server version 1.2.1 (size=4096)
Prot LocalAddress:Port Scheduler Flags
  -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
TCP  cor-32.foo.com:http wlc
  -> cor-35.foo.com:http   Tunnel  2      0          0
  -> web.foo.com:http     Tunnel  1      0          0

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Malcolm Turnbull <[email-masked]>
Date: Thu, 19 Mar 2009 08:40:41 +0000

Nelson,

I've never played with the TUN method before but I know you need to
create the tunnel on the real server as described in the docs.

i.e.
# /sbin/modprobe ipip
# ifconfig tunl0 0.0.0.0 up
# ifconfig tunl0 192.168.1.176 netmask 255.255.255.255 broadcast
192.168.1.176 up

AND make sure you sysctrls for ARP

OR:
echo 1 > /proc/sys/net/ipv4/ip_forward
# insert it if it is compiled as module
modprobe ipip
ifconfig tunl0 0.0.0.0 up
ipchains -A input -j REDIRECT 23 -d 172.26.20.110 23 -p tcp

(IPs are just from cut and paste examples)

I assume that TUN still can't be used in modern versions of Windows?

2009/3/19 Nelson Serafica <[email-masked]>

--
Regards,

Malcolm Turnbull.

Loadbalancer.org Ltd.
Phone: +44 (0)870 443 8779
http://www.loadbalancer.org/