Subject: [lvs-users] ipvsman documentation?

From: John Du <[email-masked]>
Date: Sun, 01 Mar 2009 00:37:44 -0800

Hi the list,

I am a new subscriber to this list and this is my very first post.

I have been trying to find documentation on ipvsman. The only link I can 
find is: http://wiki.inqbus.de/twiki/bin/view/Ipvsman/Dokumentation.

That link does not work.  Can you please let me know where I can find 
some documentation for it?

In particular, how can I define direct route services in service.cfg?  
No matter what I do, the service I put to this file is interpreted as NAT.

Also, what is topology.cfg for?

Thank you very much for your help.

John

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Joseph Mack NA3T <[email-masked]>
Date: Sun, 1 Mar 2009 05:35:10 -0800 (PST)

> some documentation for it?

Volker has not posted to this list in quite a while. I'd say 
from the dates in sourceforge that the project is inactive

Joe

-- 
Joseph Mack NA3T EME(B,D), FM05lw North Carolina
jmack (at) wm7d (dot) net - azimuthal equidistant map
generator at http://www.wm7d.net/azproj.shtml
Homepage http://www.austintek.com/ It's GNU/Linux!

---

From: John Du <[email-masked]>
Date: Sun, 01 Mar 2009 12:02:17 -0800

> from the dates in sourceforge that the project is inactive
Thank you for the reply.  ipvsadm works well in setting up LVS but it 
does not seem to monitor the health of the real servers to adjust the 
LVS table. That was why I wanted to use ipvsman.  I want a simple tool 
that monitors the real servers and revises the LVS table so traffic will 
not routed to dead servers.  Any recommendations?

Thank you again for help.

John

---

From: Joseph Mack NA3T <[email-masked]>
Date: Sun, 1 Mar 2009 12:40:39 -0800 (PST)

On Sun, 1 Mar 2009, John Du wrote:

> I want a simple tool that monitors the real servers and 
> revises the LVS table so traffic will not routed to dead 
> servers.  Any recommendations?

there's no simple tool. keepalived, and ldirectord are the 
two that are being maintained

Joe

---

From: John Du <[email-masked]>
Date: Sun, 01 Mar 2009 13:59:19 -0800

> two that are being maintained
OK. I'll try keepalived.  I have not found an RPM for RHEL5.  A source 
RPM I found does not build on RHEL5.  I can build the source 
distribution from the keepalived site but I prefer an RPM.

Thank you for the info.

John

---

From: Graeme Fowler <[email-masked]>
Date: Sun, 01 Mar 2009 22:07:35 +0000

On Sun, 2009-03-01 at 13:59 -0800, John Du wrote:
> OK. I'll try keepalived.

Do
Not
Use
1.1.16

Alexandre rather rushed the release, and it is significantly broken. If
you want to use keepalived, please use 1.1.15 instead.

For the first time in a very long time [1] I would suggest using
Heartbeat+Ldirectord, for the simple reason that they're very likely
included as part of your distribution. If they're not, you can grab them
from CentOS instead.

Graeme

[1] Sorry, Alexandre :(

---

From: "Kit Gerrits" <[email-masked]>
Date: Sun, 1 Mar 2009 23:14:53 +0100

You might want to look into the LVS kernel settings. 
Especially nodest_conn and expire_quiescent_template

There seems to be something in Documentation/networking/ipvs-sysctl.txt in
the linux kernel tree.

Regards,

Kit

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of John Du
Sent: zondag 1 maart 2009 22:59
To: LinuxVirtualServer.org users mailing list.
Subject: Re: [lvs-users] ipvsman documentation?

Joseph Mack NA3T wrote:
>> I want a simple tool that monitors the real servers and revises the 
>> LVS table so traffic will not routed to dead servers.  Any 
>> recommendations?
>>     
>
> there's no simple tool. keepalived, and ldirectord are the two that 
> are being maintained
>
> Joe
>
>   
OK. I'll try keepalived.  I have not found an RPM for RHEL5.  A source RPM I
found does not build on RHEL5.  I can build the source distribution from the
keepalived site but I prefer an RPM.

Thank you for the info.

John

LinuxVirtualServer.org mailing list - [email-masked] Send
requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: "XUFENG" <[email-masked]>
Date: Mon, 2 Mar 2009 15:19:12 +0800

Heartbeat with ldirectord has served in our production for years with no
problem.
Most of all it is easy to configure for use.

> [mailto:[email-masked]] On Behalf Of Kit Gerrits
> Sent: 2009年3月2日 6:15
> To: 'LinuxVirtualServer.org users mailing list.'
Send

---

From: John Du <[email-masked]>
Date: Mon, 02 Mar 2009 23:32:04 -0800

> Most of all it is easy to configure for use.

I have settled with ldirectord. It does exactly what I wanted and I
would say it is very easy to make it work.

I have not confgured heartbeat yet because at this time I do not have a
backup director server yet.

Thanks to all the people who have helped. Really appreciated your quick
helping hands!

>> OK. I'll try keepalived.  I have not found an RPM for RHEL5.  A source RPM
>>     
> I
>   
>> found does not build on RHEL5.  I can build the source distribution from
>>     
> the
>