Subject: [lvs-users] Why Are My ldirectord.log Files All Empty?

From: "Robinson, Eric" <[email-masked]>
Date: Tue, 31 Mar 2009 04:11:31 -0700

Why isn't ldirectord logging anything? I've got a couple of servers that
keep going quiescent and then restoring and I'm trying to figure out
why.

[root@lb01 log]# ls -al ldirectord.log*
-rw-r--r-- 1 root root 0 Mar 29 04:02 ldirectord.log
-rw-r--r-- 1 root root 0 Mar 22 04:02 ldirectord.log.1
-rw-r--r-- 1 root root 0 Mar 15 04:03 ldirectord.log.2
-rw-r--r-- 1 root root 0 Mar  8 04:02 ldirectord.log.3
-rw-r--r-- 1 root root 0 Mar  1 04:02 ldirectord.log.4

[root@lb01 log]# cat /etc/ha.d/ldirectord.cf |grep log
logfile="/var/log/ldirectord.log"
logfile="local0"

--
Eric Robinson

Disclaimer - March 31, 2009 
This email and any files transmitted with it are confidential and intended solely for LinuxVirtualServer.org users mailing list.. If you are not the named addressee you should not disseminate, distribute, copy or alter this email. Any views or opinions presented in this email are solely those of the author and might not represent those of Physician Select Management and Physician's Managed Care. Warning: Although Physician Select Management and Physician's Managed Care have taken reasonable precautions to ensure no viruses are present in this email, the companies cannot accept responsibility for any loss or damage arising from the use of this email or attachments. 
This disclaimer was added by Policy Patrol: http://www.policypatrol.com/

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Graeme Fowler <[email-masked]>
Date: Tue, 31 Mar 2009 12:49:51 +0100

On Tue, 2009-03-31 at 04:11 -0700, Robinson, Eric wrote:
> Why isn't ldirectord logging anything?
<snip>
> logfile="/var/log/ldirectord.log"

...because the second line overrides the first, and is sending
everything to syslog facility LOCAL0.

It'll be putting it wherever that log facility ends up - which could be
nowhere.

Graeme