Subject: [lvs-users] Do newer LVS implementations allow hairpinning?

From: "Robinson, Eric" <[email-masked]>
Date: Tue, 10 Mar 2009 20:13:33 -0700

Do newer LVS implementations allow hairpinning requests back out the
same interface they arrived on? In other words, if my load balancer has
virtual services listening on its eth0, and the realservers are on eth1,
is it possible for a client computer on eth1 to connect to the VS on
eth0 and be redirected back to one of the RS's on eth1?

--Eric

Disclaimer - March 10, 2009 
This email and any files transmitted with it are confidential and intended solely for LinuxVirtualServer.org users mailing list.. If you are not the named addressee you should not disseminate, distribute, copy or alter this email. Any views or opinions presented in this email are solely those of the author and might not represent those of . Warning: Although  has taken reasonable precautions to ensure no viruses are present in this email, the company cannot accept responsibility for any loss or damage arising from the use of this email or attachments. 
This disclaimer was added by Policy Patrol: http://www.policypatrol.com/

_______________________________________________
Please read the documentation before posting - it's available at:
http://www.linuxvirtualserver.org/

LinuxVirtualServer.org mailing list - [email-masked]
Send requests to [email-masked]
or go to http://lists.graemef.net/mailman/listinfo/lvs-users

---

From: Joseph Mack NA3T <[email-masked]>
Date: Wed, 11 Mar 2009 04:43:26 -0700 (PDT)

On Tue, 10 Mar 2009, Robinson, Eric wrote:

> Do newer LVS implementations allow hairpinning requests 
> back out the same interface they arrived on? In other 
> words, if my load balancer has virtual services listening 
> on its eth0, and the realservers are on eth1, is it 
> possible for a client computer on eth1

a client computer can be attached to any NIC on the 
director.

> to connect to the VS on eth0 and be redirected back to one 
> of the RS's on eth1?

Provided you haven't done something to block the routing, it 
should work. I don't know what "newer LVS implementations" 
has to do with this

Joe
--
Joseph Mack NA3T EME(B,D), FM05lw North Carolina
jmack (at) wm7d (dot) net - azimuthal equidistant map
generator at http://www.wm7d.net/azproj.shtml 
Homepage http://www.austintek.com/ It's GNU/Linux!